Grom USB2P was never found from Stereo after firmware update

I have a 2004 Grand Cheroke with the European RB3 Navi (OEM Chrysler/Jeep
I installed the Grom in 2013 an it works fine with USB Sticks but i had always problems with the bluetooth. My Smartphone did not connect automaticly, I did the connection always manuel an then the music from Smartphone was played from Steroa  - or not.
The Phone had allways the connection with bluetooth after do it manuel but the music from phone was rarely played. Instead of playing songs from Smatphone the most time the Grom played still from USB Stick but not always. In ca 50% the Grom did what it have do do and play from Smartphone.
Now I have spotify and wanted that it work every time.
So i read the manual and try to connect my Android Phone S5 with USB, i read this will work, but it did.
OK, after contact the German support they told me it work only with the Grom APP together with USB - so i download AALinQ ans saw this app work not with Spotify.
After download the new APP DashLinQ i noticed this app work not with the firmware from Grom.

So i did the firmware update.
But now the Stereo find never the Grom. My phone find the Grom and the App Dashlink is not longer hanging (is this the english word?)
Unfortunately my RB3 have no Buttons for FM od CD . It have ondy the Mode button wich switch the Stereo in sequence:  FM - CD - CDC (or Grom wenn found, but did never) - LW - MW (European AM) - and again FM - CD .......
So I can not try the trick with FM and CD buttons i read with other problems.

I did unconnect the Grom , the radio, use a different USB sticks...   all i try with no result.

What can i do now?

Unfortunately i sold my CDC in 2013 when i build in the Grom so i can not look if that will be recognice.
  • Hello, make sure that you downloaded correct firmware for your adapter.
    1. If you have USB2P - check its visual appearance, you need to download the firmware for USB2P car kit (not USB3). Check the serial number at the back of GROM and also its visual appearance, if the top part has "lip" (like on the image here:

    Here is the page for the older USB products such as USB2P:

    2. Make sure that you choose correct firmware for your car. Make sure that you choose the firmware for Chrysler/Dodge/Jeep.

    3. Make sure that you rename the fimrware file correctly. It should be renamed to gromusb2.hex

    It looks that the update went through, but the wrong firmware file was used - this is why the unit stopped working now.

  • I checked that all.
    I have a unit with the lip # 844C ....

    is it possible that there is the old hardware in the box with the lip?
    Can i try the "wrong" software for upto 843 unit or can i damage the box?
  • I fixed it

    It is the old hardware in the housing with the lip and # 844....
    i played the "old" firmware for non lip housing and up to # 843.... on it and now it works
  • Perfect! Glad to hear that!
Sign In or Register to comment.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Copyright © 2015, Grom Audio