USB3 and Samsung S4 streaming via USB

I thought
I'd share something interesting with the Grom community.

I recently had problems with usb audio streaming from my Samsung Galaxy S4 with
stock firmware 5.0.1 to my Grom USB3 unit. The strange fact was
that USB audio streaming from the Galaxy S3 of my daughter and the Galaxy S5
Neo of my wife did work... Hence, I assumed it was caused by the stock 5.0.1
firmware. First I rooted my phone and tried to fix the issue in the
audio_policy.conf file on my phone, but without any success. So I decided to flash an
android 6.0.1 custom rom (resurrection remix 5.7.4) on my phone, and yes this
restored USB audio streaming form my S4! The volume was low with USB debugging
turned off, but the volume was perfect with USB debugging turned on. Perfect!
Now I can charge my phone and stream the audio simultaneously, without any
annoying button pushing / connection searching with Bluetooth. The sound is
perfect over the USB cable. I hope this information is also useful to some of you.

The only annoying thing I am left with now is a stupid pop-up that appears on
my phone when I plug-in the USB cable of the Grom unit (must be triggered by
the Grom unit itself, as it directs me to a link to the Grom website). I did
not figure out yet how to turn this off. Anyone did?

  • Hello, thank you for sharing your experience with us. Can you please tell us what pop up do you get every time you plug-in the USB cable? Do you have a screenshot?
    Thank you.
  • I guess the popup wants to start AAlinq or Dashlinq automatically. For now I solved the 'problem' by installing the latter, which now starts automatically when I plug my phone into the grom unit. I don't have a screenshot right now. 
  • Ok, thank you for the information.
  • I am still looking for a solution to remove the popup, as I have the impression that the overall soundquality using the Dashling app is somewhat distored compared to using directly another music app. The popup mentions something like: "USB accessory linq has no app associated" with a http link to the grom website. Can this be disabled somehow, either in android or in the grom unit?
    Does anyone have a solution?
  • Okay, so I found out what is the real problem here causing crappy sound via Dashlinq using USB audio. If I install Dashlinq, pluging the usb cable causes a switch from USB MTP/audio out mode to USB charge only mode, thus giving crappy sound. Somehow, autostart of Dashlinq interferes with the MTP enabler app I am using to auto-connect via MTP/audio out.
    Unfortuunately, enabling USB MTP mode causes Dashlinq to restart and this again seems to somehow trigger a change of the USB mode back to charge only....
    As such, Dashlinq is currently useless for me.
    This is a pitty, because in itself the app seems quite handy. 
    Anything I can do?
  • Its not possible to disable this message pop up if no app is installed on the Android device.

    What type of Custom ROM are you running?

    What year make and model vehicle is the GROM installed into?

    What firmware version is currently on the GROM module?
    To check firmware version switch to USB mode of the GROM. While playing music from USB connected device i.e. USB flash drive, Android or Ipod/iphone (USB3/MST4 only). 
    Unplug from USB port. The track number will change and show current version number of Firmware.

  • Really a pitty that this message pop up cannot be disabled without installing Dashlinq or AAlinq.

    I am using the latest firmware for my car on the Grom USB3 unit:
    Nissan/infinity (CD, no text) GROM-USB3-NISSAN-CDC, Dec 19, 2016, version 47 gromusb2_nissan_cdc_47.hex

    The custom rom I currently use on my Galaxy S4 is Resurrection Remix 5.7.4, which runs  Android 6.0.1 (ResurrectionRemix-M-v5.7.4-20161017-jfltexx)
  • I finally found a proper solution. Instead of the MTP enabler app, I used the following Xposed solution to keep my S4 remembering the USB connection setting at MTP instead of switching to USB charge mode:

    Combined with installing Dashlinq, the latter now starts automatically when plugging-in the USB cable (instead of the annoying popup) as designed, but now without distorted sound (because MTP setting is now properly rembered). Cool, problem solved!

    I also installed Dolby Atmos on my S4, which gives even better sound!

Sign In or Register to comment.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Copyright © 2015, Grom Audio